Unknown Rocket Error in Desktop Wallet

Reported by Signal chat:

I installed the official MobileCoin desktop wallet linked below on Ubuntu but when I run it, I get a “Unknown Rocket error”. Is there anyway to fix this?

Can you confirm which release you downloaded?

I used to have the exact same error a long time ago. I fixed it by ensuring that fullservice (or mobilecoind) was running in the bg.

1 Like

I have gotten the same error on v0.3.0 as well as v0.4.0. Most of my trial has been on v0.4.0 since its the latest. I am running a fully up to date Ubuntu 21.04. I tried chmod -R +x on the entire /full-service-bin/ folder to make sure it could execute but still getting the same error.

Just as an update to this. Tried the v1.1.0 release today. Getting the same issue as this github issue (it asking for a passphrase but it has never been set up before).

I ran into the same issue, and I resolved it by:

  1. Closing the application, but letting the ledger continue to sync.
  2. Wait 5 min. I got a cup of coffee.
  3. Restarted the application, and it gave me the option to create an account or import a key.

That said, this is clearly a workaround and not the correct behavior.